On 19/11/15 09:37, Christian Borntraeger wrote: > From: David Hildenbrand <dahi@xxxxxxxxxxxxxxxxxx> > > Let's provide a function to lookup a VCPU by id. > > Reviewed-by: Christian Borntraeger <borntraeger@xxxxxxxxxx> > Reviewed-by: Dominik Dingel <dingel@xxxxxxxxxxxxxxxxxx> > Signed-off-by: David Hildenbrand <dahi@xxxxxxxxxxxxxxxxxx> > Signed-off-by: Christian Borntraeger <borntraeger@xxxxxxxxxx> > [split patch from refactoring patch] > --- > include/linux/kvm_host.h | 11 +++++++++++ > 1 file changed, 11 insertions(+) > > diff --git a/include/linux/kvm_host.h b/include/linux/kvm_host.h > index 5706a21..b9f345f 100644 > --- a/include/linux/kvm_host.h > +++ b/include/linux/kvm_host.h > @@ -460,6 +460,17 @@ static inline struct kvm_vcpu *kvm_get_vcpu(struct kvm *kvm, int i) > (vcpup = kvm_get_vcpu(kvm, idx)) != NULL; \ > idx++) > > +static inline struct kvm_vcpu *kvm_lookup_vcpu(struct kvm *kvm, int id) > +{ > + struct kvm_vcpu *vcpu; > + int i; > + > + kvm_for_each_vcpu(i, vcpu, kvm) > + if (vcpu->vcpu_id == id) > + return vcpu; > + return NULL; > +} > + Any chance that you name this function differently? Otherwise we've got two functions that sound very similar and also have similar prototypes: - kvm_get_vcpu(struct kvm *kvm, int i) - kvm_lookup_vcpu(struct kvm *kvm, int id) I'm pretty sure this will cause confusion in the future! ==> Could you maybe name the new function something like "kvm_lookup_vcpu_by_id" or "kvm_get_vcpu_by_id" instead? Also a short comment before the function would be nice to make the reader aware of the difference (e.g. when hot-plugging) between the vcpu-id and array-id. Otherwise: +1 for finally having a proper common function for this! Thomas -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html