On 02/07/2015 15:17, Eric Auger wrote: > + void (*stop_producer)(struct irq_bypass_producer *); > + void (*resume_producer)(struct irq_bypass_producer *); Also, can you call these just "stop"/"resume" ... > + void (*add_consumer)(struct irq_bypass_producer *, > + struct irq_bypass_consumer *); > + void (*del_consumer)(struct irq_bypass_producer *, > + struct irq_bypass_consumer *); > }; > > struct irq_bypass_consumer { > struct list_head node; > void *token; > - void (*add_producer)(struct irq_bypass_producer *); > - void (*del_producer)(struct irq_bypass_producer *); > + unsigned int gsi; /* the guest gsi */ > + struct kvm *kvm; > + void (*stop_consumer)(struct irq_bypass_consumer *); > + void (*resume_consumer)(struct irq_bypass_consumer *); ... and same here? The KVM functions could be named - kvm_arch_irq_bypass_add_producer - kvm_arch_irq_bypass_del_producer - kvm_arch_irq_bypass_stop - kvm_arch_irq_bypass_resume Paolo -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html