Thank you for your detailed review on several of my patches. >> >> +static int complete_fast_pio(struct kvm_vcpu *vcpu) > (complete_fast_pio_in()?) If I do a v4 I'll adopt that name. >> +{ >> + unsigned long new_rax = kvm_register_read(vcpu, VCPU_REGS_RAX); > Shouldn't we handle writes in EAX differently than in AX and AL, because > of implicit zero extension. I don't think the implicit zero extension hurts us here, but maybe there is something I'm missing that I need understand. Could you explain this further? > >> + >> + BUG_ON(!vcpu->arch.pio.count); >> + BUG_ON(vcpu->arch.pio.count * vcpu->arch.pio.size > sizeof(new_rax)); > (Looking at it again, a check for 'vcpu->arch.pio.count == 1' would be > sufficient.) I prefer the checks that are there now after your last review, especially since surrounded by BUG_ON they only run on debug kernels. > >> + >> + memcpy(&new_rax, vcpu, sizeof(new_rax)); >> + trace_kvm_pio(KVM_PIO_IN, vcpu->arch.pio.port, vcpu->arch.pio.size, >> + vcpu->arch.pio.count, vcpu->arch.pio_data); >> + kvm_register_write(vcpu, VCPU_REGS_RAX, new_rax); >> + vcpu->arch.pio.count = 0; > I think it is better to call emulator_pio_in_emulated directly, like > > emulator_pio_in_out(&vcpu->arch.emulate_ctxt, vcpu->arch.pio.size, > vcpu->arch.pio.port, &new_rax, 1); > kvm_register_write(vcpu, VCPU_REGS_RAX, new_rax); > > because we know that vcpu->arch.pio.count != 0. I think two extra lines of code in my patch vs your suggestion are worth it to a) reduce execution path length b) increase readability c) avoid breaking the abstraction by not checking the return code d) avoid any future bugs introduced by changes the function that would return a value other than 1. > > Refactoring could avoid the weird vcpu->ctxt->vcpu conversion. > (A better name is always welcome.) The pointer chasing is making me dizzy. I'm not sure why emulator_pio_in_emulated takes a x86_emulate_ctxt when all it does it immediately translate that to a vcpu and never use the x86_emulate_ctxt, why not pass the vcpu in the first place? -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html