On Fri, Feb 06, 2015 at 01:51:56PM -0500, Rik van Riel wrote: > -----BEGIN PGP SIGNED MESSAGE----- > Hash: SHA1 > > On 02/06/2015 01:23 PM, Frederic Weisbecker wrote: > > On Fri, Feb 06, 2015 at 01:20:21PM -0500, Rik van Riel wrote: On > > 02/06/2015 12:22 PM, Frederic Weisbecker wrote: > >>>> On Thu, Feb 05, 2015 at 03:23:48PM -0500, riel@xxxxxxxxxx > >>>> wrote: > >>>>> From: Rik van Riel <riel@xxxxxxxxxx> > >>>>> > >>>>> Add the expected ctx_state as a parameter to > >>>>> context_tracking_user_enter and > >>>>> context_tracking_user_exit, allowing the same functions to > >>>>> not just track kernel <> user space switching, but also > >>>>> kernel <> guest transitions. > >>>>> > >>>>> Signed-off-by: Rik van Riel <riel@xxxxxxxxxx> > >>>> > >>>> You should consider using guest_enter() and guest_exit() > >>>> instead. These are context tracking APIs too but specifically > >>>> for guest. > > > > What do you mean instead? KVM already uses those. > > > > I just wanted to avoid duplicating the code... > > > >> I mean you can call rcu_user APIs directly from > >> guest_enter/exit. You don't really need to call the > >> context_tracking_user functions since guest_enter/guest_exit > >> already handle the vtime accounting. > > I would still have to modify exception_enter and exception_exit, > and with them context_tracking_user_enter and > context_tracking_user_exit. > > We have to re-enable RCU when an exception happens. > > I suspect exceptions in a guest just trigger VMEXIT, and we > figure later why the exception happened. However, if we were > to get an exception during the code where we transition into > or out of guest mode, we would still need exception_enter > and exception_exit... Ah that's a fair point. I didn't think about that. Ok then a real IN_GUEST mode makes sense. And context_tracking_user_enter/exit() can be reused as is indeed. Just a few things then: 1) In this case rename context_tracking_user_enter/exit() to context_tracking_enter() and context_tracking_exit(), since it's not anymore about user only but about any generic context. 2) We have the "WARN_ON_ONCE(!current->mm);" condition that is a debug check specific to userspace transitions because kernel threads aren't expected to resume to userspace. Can we also expect that we never switch to/from guest from a kernel thread? AFAICS this happens from an ioctl (thus user task) in x86 for kvm. But I only know this case. 3) You might want to update a few comments that assume we only deal with userspace transitions. 4) trace_user_enter/exit() should stay user-transitions specific. Thanks. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html