2015-01-30 10:38+0100, Paolo Bonzini: > On 29/01/2015 22:48, Radim Krčmář wrote: > > + if (hweight8(new->mode) != 1) > > Better (more optimized): > > if (new->mode & (new->mode - 1)) True, hweight needs to have X86_FEATURE_POPCNT to be efficient ... Do you know of a difference with it? new->mode & (new->mode - 1) | hweight8(new->mode) != 1 lea -0x1(%rax),%edi | popcnt %edi,%eax test %eax,%edi | cmp $1,%eax > Please add a comment to kvm_irq_delivery_to_apic_fast to explain what > you are doing. Would naming it kvm_apic_need_slow_delivery(), or something, be enough? > > + if (hweight8(map->mode) != 1) { > > + /* Not deliverable with optimized map. */ > > + ret = false; > > + goto out; > > + } > > Put this before the computation of cid and mda. The cid and mda are all > wrong with a mixed map, and the result of the "if" before is influenced > by the wrong cid. Fixed by patch 8, but better get it right here. Will do, thanks. -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html