Hi Li, On 01/07/14 04:08, john.liuli wrote: > From: Li Liu <john.liuli@xxxxxxxxxx> > > HSCTLR.EE is defined as bit[25] referring to arm manual > DDI0606C.b(p1590). > > changes v1 -> v2: > 1)Use the canonical syntax for orr (orr r7, r7, #(1 << 25)) > 2)Use the ARM_BE8 macro instead of the open-coded CONFIG_CPU_BIG_ENDIAN Two things: - This log should not be part of the commit message, but placed after the "---" below (do a git format-patch, edit the file produced). - Post it also to linux-arm-kernel@xxxxxxxxxxxxxxxxxxx, as this touches the core ARM code and should be reviewed there. > Signed-off-by: Li Liu <john.liuli@xxxxxxxxxx> > --- > arch/arm/kernel/hyp-stub.S | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/arch/arm/kernel/hyp-stub.S b/arch/arm/kernel/hyp-stub.S > index 797b1a6..7e666cf 100644 > --- a/arch/arm/kernel/hyp-stub.S > +++ b/arch/arm/kernel/hyp-stub.S > @@ -134,9 +134,7 @@ ENTRY(__hyp_stub_install_secondary) > mcr p15, 4, r7, c1, c1, 3 @ HSTR > > THUMB( orr r7, #(1 << 30) ) @ HSCTLR.TE > -#ifdef CONFIG_CPU_BIG_ENDIAN > - orr r7, #(1 << 9) @ HSCTLR.EE > -#endif > +ARM_BE8(orr r7, r7, #(1 << 25)) @ HSCTLR.EE > mcr p15, 4, r7, c1, c0, 0 @ HSCTLR > > mrc p15, 4, r7, c1, c1, 1 @ HDCR > Other than that, it looks good to me. When you repost it, you can add: Reviewed-by: Marc Zyngier <marc.zyngier@xxxxxxx> Thanks, M. -- Jazz is not dead. It just smells funny... -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html