On 26/06/14 20:11, Deng-Cheng Zhu wrote: > The patches are pretty straightforward. > > Changes: > v4 - v3: > o In patch #1, align elements in debugfs_entries[]. > o In patch #1, indentation and comment style changes. > o In patch #2, use kvm_debug instead of kvm_err in kvm_mips_check_privilege(). > o Drop off the original patch #6 (MIPS: KVM: Restore correct value for WIRED at > TLB uninit). > o Drop off the original patch #7 (MIPS: KVM: Fix memory leak on VCPU), because > it has been queued. > o Change authorship of the original patch #9 (MIPS: KVM: Remove dead code of TLB > index error in kvm_mips_emul_tlbwr()), add Reported-by. Thanks. The remaining changes look good to me. Patches 1, 2, and 7: Reviewed-by: James Hogan <james.hogan@xxxxxxxxxx> Cheers James > v3 - v2: > o In patch #2, change the use of kvm_[err|info|debug]. > o In patch #3, add err removal in kvm_arch_commit_memory_region(). > o In patch #3, revert the changes to kvm_arch_vm_ioctl(). > o In patch #7, drop the merge of kvm_arch_vcpu_free() and pointer nullification. > o Add patch #9. > v2 - v1: > o In patch #1, don't change the opening comment mark for kernel-doc comments. > o In patch #1, to make long lines more readable, use local variables / macros. > o In patch #1, slight format adjustments are made. > o Use -M flag to generate patches (detect renames). > o Add patch #8. > > Deng-Cheng Zhu (7): > MIPS: KVM: Reformat code and comments > MIPS: KVM: Use KVM internal logger > MIPS: KVM: Simplify functions by removing redundancy > MIPS: KVM: Remove unneeded volatile > MIPS: KVM: Rename files to remove the prefix "kvm_" and "kvm_mips_" > MIPS: KVM: Skip memory cleaning in kvm_mips_commpage_init() > MIPS: KVM: Remove dead code of TLB index error in > kvm_mips_emul_tlbwr() > > arch/mips/include/asm/kvm_host.h | 12 +- > arch/mips/include/asm/r4kcache.h | 3 + > arch/mips/kvm/Makefile | 8 +- > arch/mips/kvm/{kvm_cb.c => callback.c} | 0 > arch/mips/kvm/commpage.c | 33 ++ > arch/mips/kvm/commpage.h | 24 + > arch/mips/kvm/{kvm_mips_dyntrans.c => dyntrans.c} | 40 +- > arch/mips/kvm/{kvm_mips_emul.c => emulate.c} | 539 +++++++++++----------- > arch/mips/kvm/{kvm_mips_int.c => interrupt.c} | 47 +- > arch/mips/kvm/{kvm_mips_int.h => interrupt.h} | 22 +- > arch/mips/kvm/kvm_mips_comm.h | 23 - > arch/mips/kvm/kvm_mips_commpage.c | 37 -- > arch/mips/kvm/kvm_mips_opcode.h | 24 - > arch/mips/kvm/{kvm_locore.S => locore.S} | 55 ++- > arch/mips/kvm/{kvm_mips.c => mips.c} | 224 +++++---- > arch/mips/kvm/opcode.h | 22 + > arch/mips/kvm/{kvm_mips_stats.c => stats.c} | 28 +- > arch/mips/kvm/{kvm_tlb.c => tlb.c} | 258 +++++------ > arch/mips/kvm/trace.h | 18 +- > arch/mips/kvm/{kvm_trap_emul.c => trap_emul.c} | 112 +++-- > 20 files changed, 750 insertions(+), 779 deletions(-) > rename arch/mips/kvm/{kvm_cb.c => callback.c} (100%) > create mode 100644 arch/mips/kvm/commpage.c > create mode 100644 arch/mips/kvm/commpage.h > rename arch/mips/kvm/{kvm_mips_dyntrans.c => dyntrans.c} (79%) > rename arch/mips/kvm/{kvm_mips_emul.c => emulate.c} (83%) > rename arch/mips/kvm/{kvm_mips_int.c => interrupt.c} (85%) > rename arch/mips/kvm/{kvm_mips_int.h => interrupt.h} (74%) > delete mode 100644 arch/mips/kvm/kvm_mips_comm.h > delete mode 100644 arch/mips/kvm/kvm_mips_commpage.c > delete mode 100644 arch/mips/kvm/kvm_mips_opcode.h > rename arch/mips/kvm/{kvm_locore.S => locore.S} (93%) > rename arch/mips/kvm/{kvm_mips.c => mips.c} (84%) > create mode 100644 arch/mips/kvm/opcode.h > rename arch/mips/kvm/{kvm_mips_stats.c => stats.c} (63%) > rename arch/mips/kvm/{kvm_tlb.c => tlb.c} (78%) > rename arch/mips/kvm/{kvm_trap_emul.c => trap_emul.c} (83%) > -- To unsubscribe from this list: send the line "unsubscribe kvm" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html