changes since v3: - use kvmppc namespace - MPP_BUFFER_ORDER of 3 not 4, as we only need 32k and it's already 32k aligned - split out kvmppc_vcore_create in separate patch - give a variable a better name: s/tmp/mpp_addr/ - logmpp becomes static inline function Stewart Smith (2): Split out struct kvmppc_vcore creation to separate function Use the POWER8 Micro Partition Prefetch Engine in KVM HV on POWER8 arch/powerpc/include/asm/cache.h | 7 +++ arch/powerpc/include/asm/kvm_host.h | 2 + arch/powerpc/include/asm/ppc-opcode.h | 17 +++++++ arch/powerpc/include/asm/reg.h | 1 + arch/powerpc/kvm/book3s_hv.c | 88 ++++++++++++++++++++++++++++----- 5 files changed, 104 insertions(+), 11 deletions(-) -- 1.7.10.4 -- To unsubscribe from this list: send the line "unsubscribe kvm-ppc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html