Re: [PATCH 3/6] kvmppc: rewrite guest code - sprg0-3

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, 2008-08-21 at 15:19 +0200, Christian Ehrhardt wrote:
> Hollis Blanchard wrote:
> > Some initial comments:
> >
> > On Tue, 2008-08-19 at 12:36 +0200,
> ehrhardt@xxxxxxxxxxxxxxxxxx wrote:
> >   
> >> +               if (rw == KVM_PPCPV_PVMEM_READ) {
> >> +                       set_op(32, &newinst); /* lwz */
> >> +                       set_rt(get_rt(inst), &newinst); /* set
> original rt */
> >> +               } else {
> >> +                       set_op(36, &newinst); /* stw */
> >> +                       set_rs(get_rs(inst), &newinst); /* set
> original rs */
> >> +               }
> >>     
> >
> > I think it's time we replaced these magic numbers (32, 36 above, but
> > also in the opcode switch statements) with named constants.
> >
> >   
> Yes, but I wanted to keep it in sync with the emulation switch code
> here.
> Once we agree on this patch series it is easy to throw a numer->name 
> patch on top.
> Or do you want me to put a renaming patch into the paravirtualization 
> queue now ?

In general I think the philosophy should be to commit patches that we
all agree on *first*, and then patches that need more thought/discussion
later. That way we don't need to wait for consensus on all outstanding
patches before committing any of them.

-- 
Hollis Blanchard
IBM Linux Technology Center

--
To unsubscribe from this list: send the line "unsubscribe kvm-ppc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [KVM Development]     [KVM ARM]     [KVM ia64]     [Linux Virtualization]     [Linux USB Devel]     [Linux Video]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Big List of Linux Books]

  Powered by Linux