> > Honestly, I'd refrain from such changes *unless* they enable something > else. The current code is well understood by people hacking on it, and > although I don't mind revamping it, it has to be for a good reason. > > I'd be much more receptive to such a change if it was a prefix to > something that actually made a significant change. > > Thanks, > > M. > Hi Marc, Thanks for the feedback. I am not sure about the style of the KVM ARM side. But in general I think mixing the generic code for ARM and specific CPU errata handling is misleading. For instance, in this case: + if ((esr & ESR_ELx_FSC_TYPE) == FSC_PERM) + return false; + + if (cpus_have_final_cap(ARM64_WORKAROUND_834220)) + return false; As shown it would be much cleaner to separate the two cases as the former case is suggested in ARMv8 Spec D13.2.55. The latter case would definitely come from a different source. But I also don't have a strong opinion pushing this one. So, let me pull it back then :) _______________________________________________ kvmarm mailing list kvmarm@xxxxxxxxxxxxxxxxxxxxx https://lists.cs.columbia.edu/mailman/listinfo/kvmarm