On Tue, Jun 15, 2021 at 02:39:40PM +0100, Fuad Tabba wrote: > Change the names of hcr_el2 register fields to match the Arm > Architecture Reference Manual. Easier for cross-referencing and > for grepping. > > Also, change the name of CPTR_EL2_RES1 to CPTR_NVHE_EL2_RES1, > because res1 bits are different for VHE. > > No functional change intended. > > Signed-off-by: Fuad Tabba <tabba@xxxxxxxxxx> > --- > arch/arm64/include/asm/kvm_arm.h | 12 ++++++------ > 1 file changed, 6 insertions(+), 6 deletions(-) > > diff --git a/arch/arm64/include/asm/kvm_arm.h b/arch/arm64/include/asm/kvm_arm.h > index 25d8a61888e4..bee1ba6773fb 100644 > --- a/arch/arm64/include/asm/kvm_arm.h > +++ b/arch/arm64/include/asm/kvm_arm.h > @@ -31,9 +31,9 @@ > #define HCR_TVM (UL(1) << 26) > #define HCR_TTLB (UL(1) << 25) > #define HCR_TPU (UL(1) << 24) > -#define HCR_TPC (UL(1) << 23) > +#define HCR_TPCP (UL(1) << 23) This one is a bit weird: the field is called TPCP if the CPU supports FEAT_DPB but is called TPC otherwise! So I don't think renaming it like this really makes anything better. Perhaps add a comment: #define HCR_TPC (UL(1) << 23) /* TPCP if FEAT_DPB */ ? Rest of the patch looks good: Acked-by: Will Deacon <will@xxxxxxxxxx> Will _______________________________________________ kvmarm mailing list kvmarm@xxxxxxxxxxxxxxxxxxxxx https://lists.cs.columbia.edu/mailman/listinfo/kvmarm