On Mon, Sep 21, 2020 at 03:53:20PM +0100, David Brazdil wrote: > > Cosmetic, but I think it would be cleaner just to define two variants of the > > macro here: > > > > #if defined(__KVM_NVHE_HYPERVISOR__) || defined(__KVM_VHE_HYPERVISOR__) > > .macro this_cpu_offset, dst > > mrs \dst, tpidr_el2 > > .endm > > #else > > .macro this_cpu_offset, dst > > alternative_if_not ARM64_HAS_VIRT_HOST_EXTN > > mrs \dst, tpidr_el1 > > alternative_else > > mrs \dst, tpidr_el2 > > alternative_endif > > .endm > > #endif > > Sure. Ta. > > (and should we have a shorthand __HYPERVISOR define to avoid the NVHE || VHE > > logic?) > > Happy to add this but let's agree on the details. > * name: just __HYPERVISOR or __KVM_HYPERVISOR__? Hey, I leave the hard decisions to others! > * defined where? I'm wary of defining it in a header file because then sombody > will forget to add it and 'ifdef HYP' will be skipped. So I'd put this as > another '-D__HYPERVISOR' in the build rules. Do you agree? Hmm, that's a good point. Leave that part as-is for now then and we can tackle it separately if it comes up again. Will _______________________________________________ kvmarm mailing list kvmarm@xxxxxxxxxxxxxxxxxxxxx https://lists.cs.columbia.edu/mailman/listinfo/kvmarm