Hi Will, On 9/7/20 4:23 PM, Will Deacon wrote: > Now that the guest stage-2 page-tables are managed independently from > the host stage-1 page-tables, we can avoid constraining the IPA size > based on the host and instead limit it only based on the PARange field > of the ID_AA64MMFR0 register. > > Cc: Marc Zyngier <maz@xxxxxxxxxx> > Cc: Quentin Perret <qperret@xxxxxxxxxx> > Reviewed-by: Gavin Shan <gshan@xxxxxxxxxx> > Signed-off-by: Will Deacon <will@xxxxxxxxxx> > --- > arch/arm64/kvm/reset.c | 38 +++++--------------------------------- > 1 file changed, 5 insertions(+), 33 deletions(-) > > diff --git a/arch/arm64/kvm/reset.c b/arch/arm64/kvm/reset.c > index ee33875c5c2a..471ee9234e40 100644 > --- a/arch/arm64/kvm/reset.c > +++ b/arch/arm64/kvm/reset.c > @@ -339,7 +339,7 @@ u32 get_kvm_ipa_limit(void) > > int kvm_set_ipa_limit(void) > { > - unsigned int ipa_max, pa_max, va_max, parange, tgran_2; > + unsigned int parange, tgran_2; > u64 mmfr0; > > mmfr0 = read_sanitised_ftr_reg(SYS_ID_AA64MMFR0_EL1); > @@ -376,38 +376,10 @@ int kvm_set_ipa_limit(void) > break; > } > > - pa_max = id_aa64mmfr0_parange_to_phys_shift(parange); > - > - /* Clamp the IPA limit to the PA size supported by the kernel */ > - ipa_max = (pa_max > PHYS_MASK_SHIFT) ? PHYS_MASK_SHIFT : pa_max; > - /* > - * Since our stage2 table is dependent on the stage1 page table code, > - * we must always honor the following condition: > - * > - * Number of levels in Stage1 >= Number of levels in Stage2. > - * > - * So clamp the ipa limit further down to limit the number of levels. > - * Since we can concatenate upto 16 tables at entry level, we could > - * go upto 4bits above the maximum VA addressable with the current > - * number of levels. > - */ > - va_max = PGDIR_SHIFT + PAGE_SHIFT - 3; > - va_max += 4; > - > - if (va_max < ipa_max) > - ipa_max = va_max; > - > - /* > - * If the final limit is lower than the real physical address > - * limit of the CPUs, report the reason. > - */ > - if (ipa_max < pa_max) > - pr_info("kvm: Limiting the IPA size due to kernel %s Address limit\n", > - (va_max < pa_max) ? "Virtual" : "Physical"); > - > - WARN(ipa_max < KVM_PHYS_SHIFT, > - "KVM IPA limit (%d bit) is smaller than default size\n", ipa_max); > - kvm_ipa_limit = ipa_max; > + kvm_ipa_limit = id_aa64mmfr0_parange_to_phys_shift(parange); > + WARN(kvm_ipa_limit < KVM_PHYS_SHIFT, > + "KVM IPA limit (%d bit) is smaller than default size\n", > + kvm_ipa_limit); > kvm_info("IPA Size Limit: %dbits\n", kvm_ipa_limit); Bikeshedding: the two messages are slightly inconsistent: "IPA limit" vs "IPA Size Limit" and "%d bit" vs "%dbits. Might be worth using the exact wording to make it painfully obvious that the messages refer to the same variable, kvm_ipa_limit. Thanks, Alex _______________________________________________ kvmarm mailing list kvmarm@xxxxxxxxxxxxxxxxxxxxx https://lists.cs.columbia.edu/mailman/listinfo/kvmarm