> -void __hyp_text __kvm_tlb_flush_vmid_ipa(struct kvm_s2_mmu *mmu, phys_addr_t ipa) > +void __hyp_text __kvm_tlb_flush_vmid_ipa(struct kvm_s2_mmu *mmu, > + phys_addr_t ipa, int level) The level feels like a good opportunity for an enum to add some documentation from the type. > static void kvm_tlb_flush_vmid_ipa(struct kvm_s2_mmu *mmu, phys_addr_t ipa) > { > - kvm_call_hyp(__kvm_tlb_flush_vmid_ipa, mmu, ipa); > + kvm_call_hyp(__kvm_tlb_flush_vmid_ipa, mmu, ipa, 0); With the constants from the next patch brought forward, the magic 0 can be given a name, although it's very temporary so.. Otherwise, looks good. _______________________________________________ kvmarm mailing list kvmarm@xxxxxxxxxxxxxxxxxxxxx https://lists.cs.columbia.edu/mailman/listinfo/kvmarm