On Fri, Dec 20, 2019 at 11:04:45AM +0100, Cornelia Huck wrote: > On Wed, 18 Dec 2019 13:55:20 -0800 > Sean Christopherson <sean.j.christopherson@xxxxxxxxx> wrote: > > > Rename kvm_arch_vcpu_setup() to kvm_s390_vcpu_setup() and manually call > > the new function during kvm_arch_vcpu_create(). Define an empty > > kvm_arch_vcpu_setup() as it's still required for compilation. This > > is effectively a nop as kvm_arch_vcpu_create() and kvm_arch_vcpu_setup() > > are called back-to-back by common KVM code. Obsoleting > > kvm_arch_vcpu_setup() paves the way for its removal. > > > > Note, gmap_remove() is now called if setup fails, as s390 was previously > > freeing it via kvm_arch_vcpu_destroy(), which is called by common KVM > > code if kvm_arch_vcpu_setup() fails. > > Yes, this looks like the only thing that needs to be undone > (sca_add_vcpu() is done later in the process.) > > Maybe mention that gmap_remove() is for ucontrol only? I was confused > for a moment :) Will do. Would it also make sense to open code __kvm_ucontrol_vcpu_init() in a separate patch immediately preceding this change? That'd make it a little more obvious why gmap_remove() is called, and it would eliminate the "uninit" verbiage in the label, e.g.: if (kvm_is_ucontrol(vcpu->kvm)) { vcpu->arch.gmap = gmap_create(current->mm, -1UL); if (!vcpu->arch.gmap) { rc = -ENOMEM; goto out_free_sie_block; } vcpu->arch.gmap->private = vcpu->kvm; } VM_EVENT(kvm, 3, "create cpu %d at 0x%pK, sie block at 0x%pK", id, vcpu, vcpu->arch.sie_block); trace_kvm_s390_create_vcpu(id, vcpu, vcpu->arch.sie_block); rc = kvm_s390_vcpu_setup(vcpu); if (rc) goto out_free_ucontrol_gmap; return 0; out_free_ucontrol_gmap: if (kvm_is_ucontrol(vcpu->kvm)) gmap_remove(vcpu->arch.gmap); out_free_sie_block: free_page((unsigned long)(vcpu->arch.sie_block)); return rc; } _______________________________________________ kvmarm mailing list kvmarm@xxxxxxxxxxxxxxxxxxxxx https://lists.cs.columbia.edu/mailman/listinfo/kvmarm