On Fri, Jun 15, 2018 at 04:47:23PM +0100, Dave P Martin wrote: > From: Mark Rutland <mark.rutland@xxxxxxx> > > Currently we have a couple of helpers to manipulate bits in particular > sysregs: > > * config_sctlr_el1(u32 clear, u32 set) > > * change_cpacr(u64 val, u64 mask) > > The parameters of these differ in naming convention, order, and size, > which is unfortunate. They also differ slightly in behaviour, as > change_cpacr() skips the sysreg write if the bits are unchanged, which > is a useful optimization when sysreg writes are expensive. > > Before we gain more yet another sysreg manipulation function, let's > unify these with a common helper, providing a consistent order for > clear/set operands, and the write skipping behaviour from > change_cpacr(). Code will be migrated to the new helper in subsequent > patches. > > Signed-off-by: Mark Rutland <mark.rutland@xxxxxxx> > Reviewed-by: Dave Martin <dave.martin@xxxxxxx> > Cc: Catalin Marinas <catalin.marinas@xxxxxxx> > Cc: Marc Zyngier <marc.zyngier@xxxxxxx> Since you are submitting this patch, it should have your signed-off-by as well. Other than that: Acked-by: Catalin Marinas <catalin.marinas@xxxxxxx> _______________________________________________ kvmarm mailing list kvmarm@xxxxxxxxxxxxxxxxxxxxx https://lists.cs.columbia.edu/mailman/listinfo/kvmarm