Re: [RFC v2 5/7] hw/arm/boot: load_dtb becomes non static

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 08/11/2014 03:10 PM, Alexander Graf wrote:
> 
> On 08.08.14 17:03, Eric Auger wrote:
>> load_dtb will be used by machvirt for dynamic instantiation of
>> platform devices
>>
>> Signed-off-by: Eric Auger <eric.auger@xxxxxxxxxx>
>> ---
>>   hw/arm/boot.c        | 2 +-
>>   include/hw/arm/arm.h | 1 +
>>   2 files changed, 2 insertions(+), 1 deletion(-)
>>
>> diff --git a/hw/arm/boot.c b/hw/arm/boot.c
>> index 1241761..53b43e8 100644
>> --- a/hw/arm/boot.c
>> +++ b/hw/arm/boot.c
>> @@ -312,7 +312,7 @@ static void set_kernel_args_old(const struct
>> arm_boot_info *info)
>>       }
>>   }
>>   -static int load_dtb(hwaddr addr, const struct arm_boot_info *binfo)
>> +int load_dtb(hwaddr addr, const struct arm_boot_info *binfo)
> 
> Please rename it arm_load_dtb then.
OK
thanks

Eric
> 
> 
> Alex
> 
>>   {
>>       void *fdt = NULL;
>>       int size, rc;
>> diff --git a/include/hw/arm/arm.h b/include/hw/arm/arm.h
>> index cbbf4ca..fe58dc0 100644
>> --- a/include/hw/arm/arm.h
>> +++ b/include/hw/arm/arm.h
>> @@ -68,6 +68,7 @@ struct arm_boot_info {
>>       hwaddr entry;
>>   };
>>   void arm_load_kernel(ARMCPU *cpu, struct arm_boot_info *info);
>> +int load_dtb(hwaddr addr, const struct arm_boot_info *binfo);
>>     /* Multiplication factor to convert from system clock ticks to
>> qemu timer
>>      ticks.  */
> 

_______________________________________________
kvmarm mailing list
kvmarm@xxxxxxxxxxxxxxxxxxxxx
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm




[Index of Archives]     [Linux KVM]     [Spice Development]     [Libvirt]     [Libvirt Users]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux