On Tue, Apr 30, 2024 at 03:03:23PM +0200, Borislav Petkov wrote: > On Tue, Apr 09, 2024 at 02:29:57PM +0300, Kirill A. Shutemov wrote: > > +1: > > + testq $X86_CR4_MCE, %r13 > > + jz 1f > > + ALTERNATIVE "", __stringify(orl $X86_CR4_MCE, %eax), X86_FEATURE_TDX_GUEST > > 1: > > Please add the below patch to your set. Those same-number labels are > just abominable. > > Thx. > > --- > From: "Borislav Petkov (AMD)" <bp@xxxxxxxxx> > Date: Tue, 30 Apr 2024 15:00:16 +0200 > Subject: [PATCH] x86/relocate_kernel: Use named labels for less confusion > > That identity_mapped() function was loving that "1" label to the point > of completely confusing its readers. > > Use named labels in each place for clarity. > > No functional changes. > > Signed-off-by: Borislav Petkov (AMD) <bp@xxxxxxxxx> > --- > arch/x86/kernel/relocate_kernel_64.S | 18 ++++++++++-------- > 1 file changed, 10 insertions(+), 8 deletions(-) > > diff --git a/arch/x86/kernel/relocate_kernel_64.S b/arch/x86/kernel/relocate_kernel_64.S > index 8e2037d78a1f..0077c9e562a7 100644 > --- a/arch/x86/kernel/relocate_kernel_64.S > +++ b/arch/x86/kernel/relocate_kernel_64.S > @@ -152,13 +152,15 @@ SYM_CODE_START_LOCAL_NOALIGN(identity_mapped) > */ > movl $X86_CR4_PAE, %eax > testq $X86_CR4_LA57, %r13 > - jz 1f > + jz no_la57 > orl $X86_CR4_LA57, %eax > -1: > +no_la57: I assume all of these new labels have to be prefixed with ".L", right? -- Kiryl Shutsemau / Kirill A. Shutemov _______________________________________________ kexec mailing list kexec@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/kexec