In the current arm64, crashkernel=,high support has been finished after several rounds of posting and careful reviewing. The code in arm64 which parses crashkernel kernel parameters firstly, then reserve memory can be a good example for other ARCH to refer to. Whereas in x86_64, the code mixing crashkernel parameter parsing and memory reserving is twisted, and looks messy. Refactoring the code to make it more readable maintainable is necessary. Here, firstly abstract the crashkernel parameter parsing code into parse_crashkernel() to make it be able to parse crashkernel=,high|low. Then abstract the crashkernel memory reserving code into a generic function reserve_crashkernel_generic(). Finally, in ARCH which crashkernel=,high support is needed, a simple arch_reserve_crashkernel() can be added to call above two functions. This can remove the duplicated implmentation code in each ARCH, like arm64, x86_64. I only change the arm64 and x86_64 implementation to make use of the generic functions to simplify code. Risc-v can be done very easily refer to the steps in arm64 and x86_64. History: - RFC patchset: https://lore.kernel.org/all/20230619055951.45620-1-bhe@xxxxxxxxxx/T/#u [RFC PATCH 0/4] kdump: add generic functions to simplify crashkernel crashkernel in architecture Dave and Philipp commented the old parse_crashkernel_common() and parse_crashkernel_generic() are quite confusing. In this formal post, I made change to address the concern by unifying all crashkernel parsing into parse_crashkernel(). Baoquan He (8): crash_core.c: remove unnecessary parameter of function crash_core: change the prototype of function parse_crashkernel() include/linux/kexec.h: move down crash_core.h including crash_core: change parse_crashkernel() to support crashkernel=,high|low parsing crash_core: add generic function to do reservation arm64: kdump: use generic interface to simplify crashkernel reservation x86: kdump: use generic interface to simplify crashkernel reservation code crash_core.c: remove unneeded functions arch/arm/kernel/setup.c | 3 +- arch/arm64/Kconfig | 3 + arch/arm64/include/asm/kexec.h | 5 + arch/arm64/mm/init.c | 140 ++-------------------- arch/ia64/kernel/setup.c | 2 +- arch/loongarch/kernel/setup.c | 4 +- arch/mips/kernel/setup.c | 3 +- arch/powerpc/kernel/fadump.c | 2 +- arch/powerpc/kexec/core.c | 2 +- arch/powerpc/mm/nohash/kaslr_booke.c | 2 +- arch/riscv/mm/init.c | 2 +- arch/s390/kernel/setup.c | 4 +- arch/sh/kernel/machine_kexec.c | 2 +- arch/x86/Kconfig | 3 + arch/x86/include/asm/kexec.h | 32 +++++ arch/x86/kernel/setup.c | 143 +++------------------- include/linux/crash_core.h | 35 +++++- include/linux/kexec.h | 14 +-- kernel/crash_core.c | 170 +++++++++++++++++++++++---- 19 files changed, 266 insertions(+), 305 deletions(-) -- 2.41.0 _______________________________________________ kexec mailing list kexec@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/kexec