Hi Mimi, > Remove the few bashisms in the script and use the complete option name > for clarity. > Signed-off-by: Mimi Zohar <zohar@xxxxxxxxxxxxx> Reviewed-by: Petr Vorel <pvorel@xxxxxxx> > --- > tools/testing/selftests/ima/test_kexec_load.sh | 14 +++++++------- > 1 file changed, 7 insertions(+), 7 deletions(-) > diff --git a/tools/testing/selftests/ima/test_kexec_load.sh b/tools/testing/selftests/ima/test_kexec_load.sh > index 1c10093fb526..74423c4229e2 100755 > --- a/tools/testing/selftests/ima/test_kexec_load.sh > +++ b/tools/testing/selftests/ima/test_kexec_load.sh > @@ -1,7 +1,7 @@ > #!/bin/sh > # SPDX-License-Identifier: GPL-2.0+ # SPDX-License-Identifier: GPL-2.0-or-later According to [1] GPL-2.0+ has been deprecated (but who cares). ... > - if [ "$secureboot" == "1" ]; then > +kexec --load $KERNEL_IMAGE 2>&1 /dev/null kexec --load $KERNEL_IMAGE 2>&1 >/dev/null missing redirection. > +if [ $? -eq 0 ]; then > + kexec --unload > + if [ $secureboot -eq 1 ]; then > echo "$TEST: kexec_load succeeded [FAIL]" > rc=1 > else > echo "$TEST: kexec_load succeeded [PASS]" > fi It'd be nice, if selftest has some main library with helpers (like LTP has [2]), to have unified output and reduce duplicity. Kind regards, Petr [1] https://spdx.org/licenses/ [2] https://github.com/linux-test-project/ltp/blob/master/testcases/lib/tst_test.sh _______________________________________________ kexec mailing list kexec@xxxxxxxxxxxxxxxxxxx http://lists.infradead.org/mailman/listinfo/kexec