On Thu, 24 Sep 2015 11:29:42 +0800 Baoquan He <bhe at redhat.com> wrote: > On 09/23/15 at 06:56am, Petr Tesarik wrote: > > kexec/arch/i386/crashdump-x86.c | 21 +++++++-------------- > > kexec/arch/i386/kexec-x86-common.c | 4 ++-- > > kexec/kexec.h | 2 +- > > 3 files changed, 10 insertions(+), 17 deletions(-) > > > > diff --git a/kexec/arch/i386/crashdump-x86.c b/kexec/arch/i386/crashdump-x86.c > > index 63959b7..9d866cc 100644 > > --- a/kexec/arch/i386/crashdump-x86.c > > +++ b/kexec/arch/i386/crashdump-x86.c > > @@ -1026,24 +1026,17 @@ int load_crashdump_segments(struct kexec_info *info, char* mod_cmdline, > > return 0; > > } > > > > -int get_max_crash_kernel_limit(uint64_t *start, uint64_t *end) > > +/* On x86, the kernel may make a low reservation in addition to the > > + * normal reservation. However, the kernel refuses to load the panic > > + * kernel to low memory, so always choose the highest range. > > + */ > > +int get_crash_kernel_range(uint64_t *start, uint64_t *end) > > How about get_crash_kernel_load_range? In kernel crashk_res and > crashk_low_res are all named as "Crash kernel", but only crashk_res is > used to load kernel/initrd stuffs. I'm glad this patch is getting a bikeshedding kind of discussion. ;-) I don't mind calling the function whatever you like. So let's make it get_crash_kernel_load_range. Wait for v3. ;-) Petr Tesarik