On Mon, Jan 12, 2015 at 03:06:19PM +0800, Li, Zhen-Hua wrote: > Allow specification of the domain-id for the new domain. > This patch only adds the 'did' parameter to iommu_attach_domain() > and modifies all of its callers to specify the default value of -1 > which says "no did specified, allocate a new one". I think its better to keep the old iommu_attach_domain() interface in place and introduce a new function (like iommu_attach_domain_with_id() or something) which has the additional parameter. Then you can rewrite iommu_attach_domain(): iommu_attach_domai(...) { return iommu_attach_domain_with_id(..., -1); } This way you don't have to update all the callers of iommu_attach_domain() and the interface is more readable. Joerg