On 11/20/13 at 12:50pm, Vivek Goyal wrote: > diff --git a/arch/x86/kernel/machine_kexec_64.c b/arch/x86/kernel/machine_kexec_64.c > index 4eabc16..fb41b73 100644 > --- a/arch/x86/kernel/machine_kexec_64.c > +++ b/arch/x86/kernel/machine_kexec_64.c > @@ -22,6 +22,13 @@ > #include <asm/mmu_context.h> > #include <asm/debugreg.h> > > +/* arch dependent functionality related to kexec file based syscall */ > +static struct kexec_file_type kexec_file_type[]={ > + {"", NULL, NULL, NULL, NULL}, > +}; > + > + > +void *arch_kexec_kernel_image_load(struct kimage *image, char *kernel, > + unsigned long kernel_len, char *initrd, > + unsigned long initrd_len, char *cmdline, > + unsigned long cmdline_len) > +{ > + int idx = image->file_handler_idx; > + > + if (idx < 0) > + return ERR_PTR(-ENOEXEC); > + > + return kexec_file_type[idx].load(image, kernel, kernel_len, initrd, > + initrd_len, cmdline, cmdline_len); > +} > + > +int arch_image_file_post_load_cleanup(struct kimage *image) > +{ Hi Vivek, This function is defined as one of arch specific fucntion set, why don't we name it in a unified prefix as others. And name of the default dummy function in kernel/kexec.c is not consistent with the arch specific one, so currently arch_image_file_post_load_cleanup of x86 arch is not called. Please consider wihch one need be changed. > + > +void __attribute__ ((weak)) > +arch_kimage_file_post_load_cleanup(struct kimage *image) > +{ > + return; > +} > +