On Wed, May 15, 2013 at 06:06:14PM +0900, HATAYAMA Daisuke wrote: [..] > +static int __init get_note_number_and_size_elf32(const Elf32_Ehdr *ehdr_ptr, > + int *nr_ptnote, u64 *phdr_sz) > +{ > + return process_note_headers_elf32(ehdr_ptr, nr_ptnote, phdr_sz, NULL); > +} > + > +static int __init copy_notes_elf32(const Elf32_Ehdr *ehdr_ptr, char *notes_buf) > +{ > + return process_note_headers_elf32(ehdr_ptr, NULL, NULL, notes_buf); > +} > + Please don't do this. We need to create two separate functions doing two different operations and not just create wrapper around a function which does two things. I know both functions will have similar for loops for going through the elf notes but it is better then doing function overloading based on parameters passed. Vivek