On 11/23/2011 09:46 PM, Michael Holzheu wrote: > Hi Dave, > > On Wed, 2011-11-23 at 21:34 +0800, Dave Young wrote: >> On 11/23/2011 09:18 PM, Michael Holzheu wrote: >> >>> From: Michael Holzheu <holzheu at linux.vnet.ibm.com> >>> >>> Currently it is possible to set the crash_size via the sysfs >>> /sys/kernel/kexec_crash_size even if no crash kernel memory has >>> been defined with the "crashkernel" parameter. In this case >>> "crashk_res" is not initialized and crashk_res.start = crashk_res.end = 0. >>> Unfortunately resource_size(&crashk_res) returns 1 in this case. >>> This breaks the s390 implementation of crash_(un)map_reserved_pages(). >>> >>> To fix the problem the correct "old_size" is now calculated in >>> crash_shrink_memory(). "old_size is set to "0" if crashk_res is >>> not initialized. With this change crash_shrink_memory() will do nothing, >>> when "crashk_res" is not initialized. It will return "0" for >>> "echo 0 > /sys/kernel/kexec_crash_size" and -EINVAL for >>> "echo [not zero] > /sys/kernel/kexec_crash_size". >>> >>> In addition to that this patch also simplifies the "ret = -EINVAL" >>> vs. "ret = 0" logic as suggested by Simon Horman. >>> >>> Cc: Simon Horman <horms at verge.net.au> >>> Signed-off-by: Michael Holzheu <holzheu at linux.vnet.ibm.com> >>> --- >>> kernel/kexec.c | 10 ++++------ >>> 1 file changed, 4 insertions(+), 6 deletions(-) >>> >>> --- a/kernel/kexec.c >>> +++ b/kernel/kexec.c >>> @@ -1131,7 +1131,7 @@ void __weak crash_free_reserved_phys_ran >>> int crash_shrink_memory(unsigned long new_size) >>> { >>> int ret = 0; >>> - unsigned long start, end; >>> + unsigned long start, end, old_size; >> >> >> Sorry for jump in a little late, instead of introduce a new variable, >> why not add something like: >> >> if (!end) >> return -EINVAL; > > If the crashkernel parameter is not set, "/sys/kernel/kexec_crash_size" > returns zero: > > cat /sys/kernel/kexec_crash_size > 0 > > So I think if we set it again to zero we should *not* return -EINVAL: Thanks, I missed this case. fair enough. Reviewed-by: Dave Young <dyoung at redhat.com> > > echo 0 > /sys/kernel/kexec_crash_size > --> Exit code should be zero in this case > > Otherwise we would change the current behavior. > > And besides of that, I think introducing the "old_size" variable makes > the code more readable. > > Michael > > -- Thanks Dave