On Tue, 2011-08-02 at 14:55 -0400, Vivek Goyal wrote: > On Tue, Aug 02, 2011 at 11:30:03AM +0200, Michael Holzheu wrote: > > Hello Vivek, > > > > On Mon, 2011-08-01 at 16:31 -0400, Vivek Goyal wrote: > > > On Wed, Jul 27, 2011 at 02:55:06PM +0200, Michael Holzheu wrote: > > > > [snip] > > > > > > --- a/kernel/kexec.c > > > > +++ b/kernel/kexec.c > > > > @@ -842,8 +842,8 @@ out: > > > > return result; > > > > } > > > > > > > > -static int kimage_load_crash_segment(struct kimage *image, > > > > - struct kexec_segment *segment) > > > > +int __weak kimage_load_crash_segment(struct kimage *image, > > > > + struct kexec_segment *segment) > > > > > > A comment here why we are making it weak should help in increasing > > > the code readability. > > > > What about the following: > > > > /* > > * Load crash segment into memory. Architecture code can override this > > * function. E.g. this is necessary for architectures that do not > > * create page tables for crashkernel memory. > > */ > > int __weak kimage_load_crash_segment(struct kimage *image, > > This looks better. With that comment change: Do I get an "Acked-by" for this patch from you? Michael