Hi Andrew, I updated the cleanup patchset for add-vmcoreinfo.patch. * Cleanup add-vmcoreinfo.patch v1: http://www.ussg.iu.edu/hypermail/linux/kernel/0709.1/0318.html This patchset (v2) includes a new patch[4/4] for adding a prefix "VMCOREINFO_" to the vmcoreinfo macros. Other patches ([1/4]-[3/4]) don't have any changes. Changelog: - Add "Add a prefix VMCOREINFO_ to the vmcoreinfo macros" patch. Patchset: [1/4] Cleanup the coding style according to Andrew's comments: http://lists.infradead.org/pipermail/kexec/2007-August/000522.html - vmcoreinfo_append_str() should have suitable __attribute__s so that the compiler can check its use. - vmcoreinfo_max_size should have size_t. - Use get_seconds() instead of xtime.tv_sec. - Use init_uts_ns.name.release instead of UTS_RELEASE. [2/4] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data. The dump filetering command 'makedumpfile'(v1.1.6 or before) had assumed the above values, and it was not good from the reliability viewpoint. So makedumpfile v1.2.0 came to need these values and I created the patch to let the kernel output them. makedumpfile site: https://sourceforge.net/projects/makedumpfile/ [3/4] Use the existing ia64_tpa() instead of asm code. [4/4] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros. Old vmcoreinfo macros were defined as generic names SYMBOL/SIZE/OFFSET /LENGTH/CONFIG, and it is impossible to grep for them. So these names should be changed. This discussion is the following: http://www.ussg.iu.edu/hypermail/linux/kernel/0709.1/0415.html Thanks Ken'ichi Ohmichi