On Tue, 2007-10-16 at 20:44 +0200, Bernhard Walle wrote: > * Dave Hansen <haveblue at us.ibm.com> [2007-10-16 20:08]: > > On Tue, 2007-10-16 at 18:28 +0200, Bernhard Walle wrote: > > > > > > @@ -736,7 +736,7 @@ static int __init smp_scan_config (unsig > > > smp_found_config = 1; > > > printk(KERN_INFO "found SMP MP-table at %08lx\n", > > > virt_to_phys(mpf)); > > > - reserve_bootmem(virt_to_phys(mpf), PAGE_SIZE); > > > + reserve_bootmem(virt_to_phys(mpf), PAGE_SIZE, 0); > > > if (mpf->mpf_physptr) { > > > /* > > > > Could you give all of these 0's a name? I really hate seeing random > > magic numbers in these things. 0 completely kills the ability of > > someone to read the code and figure out what it is trying to do without > > going and looking at reserve_bootmem(). > > Of course I can replace that zeroes with something like BOOTMEM_DEFAULT. Cool. > > Or, alternatively, do something like this: > > > > -extern void reserve_bootmem(unsigned long addr, unsigned long size); > > Andi was against more bootmem functions. ;) Yeah, I can't really blame him. -- Dave