Vivek Goyal wrote: > On Thu, Oct 04, 2007 at 08:38:34PM +0900, Takenori Nagano wrote: >> This patch adds new notifier function tunable_notifier_chain. Its base is >> atomic_notifier_chain. >> >> Thanks, >> >> --- >> >> Signed-off-by: Takenori Nagano <t-nagano at ah.jp.nec.com> >> >> --- >> diff -uprN linux-2.6.23-rc9.orig/include/linux/notifier.h >> linux-2.6.23-rc9/include/linux/notifier.h >> --- linux-2.6.23-rc9.orig/include/linux/notifier.h 2007-10-02 12:24:52.000000000 >> +0900 >> +++ linux-2.6.23-rc9/include/linux/notifier.h 2007-10-03 14:48:04.288000000 +0900 >> @@ -13,6 +13,7 @@ >> #include <linux/mutex.h> >> #include <linux/rwsem.h> >> #include <linux/srcu.h> >> +#include <linux/kobject.h> >> >> /* >> * Notifier chains are of four types: >> @@ -53,6 +54,14 @@ struct notifier_block { >> int priority; >> }; >> >> +struct tunable_notifier_block { >> + struct notifier_block *nb; >> + struct tunable_notifier_head *head; >> + struct dentry *dir; >> + struct dentry *pri_dentry; >> + struct dentry *desc_dentry; >> +}; >> + > > Should this be tunable_atomic_notifier_block? I think there are two kind > of lists. One where handlers have to be atomic and other one where handlers > can be blocking one. I think you are making atomic one tunable. If that's > the case it should be reflected in the naming everywhere. Hi Vivek, Yes, it based on atomic_notifier_list. I think your opinion is reasonable. I'll change the name tunable_notifier to tunable_atomic_notifier. Thanks, Takenori Nagano <t-nagano at ah.jp.nec.com>