On Mon, 2020-03-30 at 10:20 +0800, Jason Yan wrote: > This is a try to implement KASLR for Freescale BookE64 which is based on > my earlier implementation for Freescale BookE32: > https://patchwork.ozlabs.org/project/linuxppc-dev/list/?series=131718&state=* > > The implementation for Freescale BookE64 is similar as BookE32. One > difference is that Freescale BookE64 set up a TLB mapping of 1G during > booting. Another difference is that ppc64 needs the kernel to be > 64K-aligned. So we can randomize the kernel in this 1G mapping and make > it 64K-aligned. This can save some code to creat another TLB map at > early boot. The disadvantage is that we only have about 1G/64K = 16384 > slots to put the kernel in. > > KERNELBASE > > 64K |--> kernel <--| > | | | > +--+--+--+ +--+--+--+--+--+--+--+--+--+ +--+--+ > | | | |....| | | | | | | | | |....| | | > +--+--+--+ +--+--+--+--+--+--+--+--+--+ +--+--+ > | | 1G > |-----> offset <-----| > > kernstart_virt_addr > > I'm not sure if the slot numbers is enough or the design has any > defects. If you have some better ideas, I would be happy to hear that. > > Thank you all. > > v4->v5: > Fix "-Werror=maybe-uninitialized" compile error. > Fix typo "similar as" -> "similar to". > v3->v4: > Do not define __kaslr_offset as a fixed symbol. Reference __run_at_load > and > __kaslr_offset by symbol instead of magic offsets. > Use IS_ENABLED(CONFIG_PPC32) instead of #ifdef CONFIG_PPC32. > Change kaslr-booke32 to kaslr-booke in index.rst > Switch some instructions to 64-bit. > v2->v3: > Fix build error when KASLR is disabled. > v1->v2: > Add __kaslr_offset for the secondary cpu boot up. > > Jason Yan (6): > powerpc/fsl_booke/kaslr: refactor kaslr_legal_offset() and > kaslr_early_init() > powerpc/fsl_booke/64: introduce reloc_kernel_entry() helper > powerpc/fsl_booke/64: implement KASLR for fsl_booke64 > powerpc/fsl_booke/64: do not clear the BSS for the second pass > powerpc/fsl_booke/64: clear the original kernel if randomized > powerpc/fsl_booke/kaslr: rename kaslr-booke32.rst to kaslr-booke.rst > and add 64bit part > > Documentation/powerpc/index.rst | 2 +- > .../{kaslr-booke32.rst => kaslr-booke.rst} | 35 ++++++- > arch/powerpc/Kconfig | 2 +- > arch/powerpc/kernel/exceptions-64e.S | 23 +++++ > arch/powerpc/kernel/head_64.S | 13 +++ > arch/powerpc/kernel/setup_64.c | 3 + > arch/powerpc/mm/mmu_decl.h | 23 +++-- > arch/powerpc/mm/nohash/kaslr_booke.c | 91 +++++++++++++------ > 8 files changed, 147 insertions(+), 45 deletions(-) > rename Documentation/powerpc/{kaslr-booke32.rst => kaslr-booke.rst} (59%) > Acked-by: Scott Wood <oss@xxxxxxxxxxxx> -Scott