Re: [PATCH v3 3/3] io_uring/napi: add static napi tracking strategy

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, 2024-09-18 at 20:59 -0600, Jens Axboe wrote:
> On 9/18/24 6:59 AM, Olivier Langlois wrote:
> > add the static napi tracking strategy that allows the user to
> > manually
> > manage the napi ids list to busy poll and offload the ring from
> > dynamically update the list.
> 
> Add the static napi tracking strategy. That allows the user to
> manually
> manage the napi ids list for busy polling, and eliminate the overhead
> of
> dynamically updating the list from the fast path.
> 
> Maybe?

ok
> 
> > index b1e0e0d85349..6f0e40e1469c 100644
> > --- a/io_uring/fdinfo.c
> > +++ b/io_uring/fdinfo.c
> > @@ -46,6 +46,46 @@ static __cold int io_uring_show_cred(struct
> > seq_file *m, unsigned int id,
> >  	return 0;
> >  }
> >  
> > +#ifdef CONFIG_NET_RX_BUSY_POLL
> > +static __cold void common_tracking_show_fdinfo(struct io_ring_ctx
> > *ctx,
> > +					       struct seq_file *m,
> > +					       const char
> > *tracking_strategy)
> > +{
> > +	seq_puts(m, "NAPI:\tenabled\n");
> > +	seq_printf(m, "napi tracking:\t%s\n", tracking_strategy);
> > +	seq_printf(m, "napi_busy_poll_dt:\t%llu\n", ctx-
> > >napi_busy_poll_dt);
> > +	if (ctx->napi_prefer_busy_poll)
> > +		seq_puts(m, "napi_prefer_busy_poll:\ttrue\n");
> > +	else
> > +		seq_puts(m, "napi_prefer_busy_poll:\tfalse\n");
> > +}
> > +
> > +static __cold void napi_show_fdinfo(struct io_ring_ctx *ctx,
> > +				    struct seq_file *m)
> > +{
> > +	unsigned int mode = READ_ONCE(ctx->napi_track_mode);
> > +
> > +	switch (mode) {
> > +	case IO_URING_NAPI_TRACKING_INACTIVE:
> > +		seq_puts(m, "NAPI:\tdisabled\n");
> > +		break;
> > +	case IO_URING_NAPI_TRACKING_DYNAMIC:
> > +		common_tracking_show_fdinfo(ctx, m, "dynamic");
> > +		break;
> > +	case IO_URING_NAPI_TRACKING_STATIC:
> > +		common_tracking_show_fdinfo(ctx, m, "static");
> > +		break;
> > +	default:
> > +		seq_printf(m, "NAPI:\tunknown mode (%u)\n", mode);
> > +	}
> > +}
> > +#else
> > +static inline void napi_show_fdinfo(struct io_ring_ctx *ctx,
> > +				    struct seq_file *m)
> > +{
> > +}
> > +#endif
> 
> I think this code should go in napi.c, with the stub
> CONFIG_NET_RX_BUSY_POLL in napi.h. Not a huge deal.
> 
> This also conflicts with your previous napi patch adding fdinfo
> support.
> What kernel is this patchset based on? You should rebase it
> for-6.12/io_uring, then it should apply to the development branch
> going
> forward too.

The repo used is Linus head. Yes I was surprised to not see my own
patch there. Kernel dev process is still a bit obscure to me... but I
figured that the conflict would be very trivial to solve. Basically,
simply drop the previous patch to replace it with this one.

but yes. I can rebase the patch into your repo. Can you provide me the
URL of your repo?

About your suggestion to move stuff in napi.h. I did though about it.
In fact, the code was there at some point before submission (or in v1).
but I did conclude the exact opposite. That it would be cleaner to keep
the fdinfo stuff together instead of polluting napi TU with it...

with this argument, if you still prefer to see that code in napi TU, I
will move it there.
> 
> > diff --git a/io_uring/napi.c b/io_uring/napi.c
> > index 6fc127e74f10..d98b87d346ca 100644
> > --- a/io_uring/napi.c
> > +++ b/io_uring/napi.c
> > @@ -38,22 +38,14 @@ static inline ktime_t net_to_ktime(unsigned
> > long t)
> >  	return ns_to_ktime(t << 10);
> >  }
> >  
> > -void __io_napi_add(struct io_ring_ctx *ctx, struct socket *sock)
> > +int __io_napi_add_id(struct io_ring_ctx *ctx, unsigned int
> > napi_id)
> >  {
> >  	struct hlist_head *hash_list;
> > -	unsigned int napi_id;
> > -	struct sock *sk;
> >  	struct io_napi_entry *e;
> >  
> > -	sk = sock->sk;
> > -	if (!sk)
> > -		return;
> > -
> > -	napi_id = READ_ONCE(sk->sk_napi_id);
> > -
> >  	/* Non-NAPI IDs can be rejected. */
> >  	if (napi_id < MIN_NAPI_ID)
> > -		return;
> > +		return -EINVAL;
> >  
> >  	hash_list = &ctx->napi_ht[hash_min(napi_id, HASH_BITS(ctx-
> > >napi_ht))];
> >  
> > @@ -62,13 +54,13 @@ void __io_napi_add(struct io_ring_ctx *ctx,
> > struct socket *sock)
> >  	if (e) {
> >  		WRITE_ONCE(e->timeout, jiffies + NAPI_TIMEOUT);
> >  		rcu_read_unlock();
> > -		return;
> > +		return -EEXIST;
> >  	}
> >  	rcu_read_unlock();
> >  
> >  	e = kmalloc(sizeof(*e), GFP_NOWAIT);
> >  	if (!e)
> > -		return;
> > +		return -ENOMEM;
> >  
> >  	e->napi_id = napi_id;
> >  	e->timeout = jiffies + NAPI_TIMEOUT;
> > @@ -77,12 +69,37 @@ void __io_napi_add(struct io_ring_ctx *ctx,
> > struct socket *sock)
> >  	if (unlikely(io_napi_hash_find(hash_list, napi_id))) {
> >  		spin_unlock(&ctx->napi_lock);
> >  		kfree(e);
> > -		return;
> > +		return -EEXIST;
> >  	}
> 
> You could abstract this out to a prep patch, having __io_napi_add()
> return an error value. That would leave the meat of your patch
> simpler
> and easier to review.

ok
> 
> > +static int __io_napi_del_id(struct io_ring_ctx *ctx, unsigned int
> > napi_id)
> > +{
> > +	struct hlist_head *hash_list;
> > +	struct io_napi_entry *e;
> > +
> > +	/* Non-NAPI IDs can be rejected. */
> > +	if (napi_id < MIN_NAPI_ID)
> > +		return -EINVAL;
> > +
> > +	hash_list = &ctx->napi_ht[hash_min(napi_id, HASH_BITS(ctx-
> > >napi_ht))];
> > +	spin_lock(&ctx->napi_lock);
> > +	e = io_napi_hash_find(hash_list, napi_id);
> > +	if (unlikely(!e)) {
> > +		spin_unlock(&ctx->napi_lock);
> > +		return -ENOENT;
> > +	}
> > +
> > +	list_del_rcu(&e->list);
> > +	hash_del_rcu(&e->node);
> > +	kfree_rcu(e, rcu);
> > +	spin_unlock(&ctx->napi_lock);
> > +	return 0;
> >  }
> 
> For new code, not a bad idea to use:
> 
> 	guard(spinlock)(&ctx->napi_lock);
> 
> Only one cleanup path here, but...

first time I hear about this... Some sort of RAII where the compiler
adds automatically unlock function call at every exit points?

ok, I'll look into it
> 
> >  static void __io_napi_remove_stale(struct io_ring_ctx *ctx)
> > @@ -141,8 +158,26 @@ static bool io_napi_busy_loop_should_end(void
> > *data,
> >  	return false;
> >  }
> >  
> > -static bool __io_napi_do_busy_loop(struct io_ring_ctx *ctx,
> > -				   void *loop_end_arg)
> > +/*
> > + * never report stale entries
> > + */
> > +static bool static_tracking_do_busy_loop(struct io_ring_ctx *ctx,
> > +					 void *loop_end_arg)
> > +{
> > +	struct io_napi_entry *e;
> > +	bool (*loop_end)(void *, unsigned long) = NULL;
> > +
> > +	if (loop_end_arg)
> > +		loop_end = io_napi_busy_loop_should_end;
> > +
> > +	list_for_each_entry_rcu(e, &ctx->napi_list, list)
> > +		napi_busy_loop_rcu(e->napi_id, loop_end,
> > loop_end_arg,
> > +				   ctx->napi_prefer_busy_poll,
> > BUSY_POLL_BUDGET);
> > +	return false;
> > +}
> > +
> > +static bool dynamic_tracking_do_busy_loop(struct io_ring_ctx *ctx,
> > +					  void *loop_end_arg)
> >  {
> >  	struct io_napi_entry *e;
> >  	bool (*loop_end)(void *, unsigned long) = NULL;
> 
> This is somewhat convoluted, but I think it'd be cleaner to have a
> prep
> patch that just passes in both loop_end and loop_end_arg to the
> caller?
> Some of this predates your changes here, but seems there's room for
> cleaning this up. What do you think?

I am not sure that I see your point that it would make the code
cleaner. TBH, I did not fully understood what was the point of the
whole loop_end business thing but since it was unrelated to my changes,
I did leave that thing undisturbed.

I'll take a second look at it to see if I can clean this up a bit...
> 
> > diff --git a/io_uring/napi.h b/io_uring/napi.h
> > index 27b88c3eb428..220574522484 100644
> > --- a/io_uring/napi.h
> > +++ b/io_uring/napi.h
> > @@ -54,13 +54,20 @@ static inline void io_napi_add(struct io_kiocb
> > *req)
> >  {
> >  	struct io_ring_ctx *ctx = req->ctx;
> >  	struct socket *sock;
> > +	struct sock *sk;
> >  
> > -	if (!READ_ONCE(ctx->napi_enabled))
> > +	if (READ_ONCE(ctx->napi_track_mode) !=
> > IO_URING_NAPI_TRACKING_DYNAMIC)
> >  		return;
> >  
> >  	sock = sock_from_file(req->file);
> > -	if (sock)
> > -		__io_napi_add(ctx, sock);
> > +	if (!sock)
> > +		return;
> > +
> > +	sk = sock->sk;
> > +	if (!sk)
> > +		return;
> > +
> > +	__io_napi_add_id(ctx, READ_ONCE(sk->sk_napi_id));
> >  }
> 
> I like having this follow the expected outcome, which is that sock
> and
> sk are valid.
> 
> 	sock = sock_from_file(req->file);
> 	if (sock && sock->sk)
> 		__io_napi_add_id(ctx, READ_ONCE(sock->sk-
> >sk_napi_id));
> 
> or something like that. At least to me that's more readable.
> 
ok.

All those points will be addressed in v4







[Index of Archives]     [Linux Samsung SoC]     [Linux Rockchip SoC]     [Linux Actions SoC]     [Linux for Synopsys ARC Processors]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]


  Powered by Linux