Re: [PATCH 7/9] mm: Add deferred_list page flag

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 15.08.23 17:32, Matthew Wilcox wrote:
On Tue, Aug 15, 2023 at 09:54:36AM +0200, David Hildenbrand wrote:
On 15.08.23 05:26, Matthew Wilcox (Oracle) wrote:
Stored in the first tail page's flags, this flag replaces the destructor.
That removes the last of the destructors, so remove all references to
folio_dtor and compound_dtor.

Signed-off-by: Matthew Wilcox (Oracle) <willy@xxxxxxxxxxxxx>


+	/* Has a deferred list (may be empty).  First tail page. */
+	PG_deferred_list = PG_reclaim,

If PG_deferred_list implies thp (and replaces the thp dtor), should we
rather name this PG_thp or something along those lines?

We're trying to use 'thp' to mean 'a folio which is pmd mappable',
so I'd rather not call it that.

There is no conclusion on that.

And I am not sure if inventing new terminology will help anybody (both, users and developers). Just call the old thing "PMD-sized THP".

After all, the deferred split queue is just an implementation detail, and it happens to live in tailpage 2, no?

Once we would end up initializing something else in prep_transhuge_page(), it would turn out pretty confusing if that is called folio_remove_deferred() ...

In the end, I don't care as long as it doesn't add confusion; this did. We most probably won't reach a conclusion here and that shouldn't block this patch set.

So at least prep_transhuge_page() should not be renamed to folio_remove_deferred() imho ...


David / dhildenb

[Index of Archives]     [Linux Samsung SoC]     [Linux Rockchip SoC]     [Linux Actions SoC]     [Linux for Synopsys ARC Processors]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux