On Wed, Jul 12, 2023 at 10:20:17AM -0600, Jens Axboe wrote: > int io_futex_prep(struct io_kiocb *req, const struct io_uring_sqe *sqe); > +int io_futexv_prep(struct io_kiocb *req, const struct io_uring_sqe *sqe); > int io_futex_wait(struct io_kiocb *req, unsigned int issue_flags); > +int io_futex_waitv(struct io_kiocb *req, unsigned int issue_flags); > int io_futex_wake(struct io_kiocb *req, unsigned int issue_flags); That's an inconsistent naming convention.. I'll stare at the rest later.