On 11/26/21 10:07, Hao Xu wrote:
v4->v5 - change the implementation of merge_wq_list v5->v6 - change the logic of handling prior task list to: 1) grabbed uring_lock: leverage the inline completion infra 2) otherwise: batch __req_complete_post() calls to save completion_lock operations.
FYI, took 5/6 into another patchset to avoid conflicts. also, you can remove "[pavel: ...]" from patches, I was just leaving them as a hint that the patches were very slightly modified. I'll retest/etc. once you fix 6/6. Hopefully, will be merged soon, the patches already had been bouncing around for too long.
Hao Xu (6): io-wq: add helper to merge two wq_lists io_uring: add a priority tw list for irq completion work io_uring: add helper for task work execution code io_uring: split io_req_complete_post() and add a helper io_uring: move up io_put_kbuf() and io_put_rw_kbuf() io_uring: batch completion in prior_task_list fs/io-wq.h | 22 +++++++ fs/io_uring.c | 168 ++++++++++++++++++++++++++++++++++---------------- 2 files changed, 136 insertions(+), 54 deletions(-)
-- Pavel Begunkov