On 2/28/21 3:35 PM, Pavel Begunkov wrote: > 1-7 are just random stuff > 8-12 are further cleanups for around prep_async > > based on io_uring-worker.v4, but should apply fine to for-next > > Pavel Begunkov (12): > io_uring: avoid taking ctx refs for task-cancel > io_uring: reuse io_req_task_queue_fail() > io_uring: further deduplicate file slot selection > io_uring: add a helper failing not issued requests > io_uring: refactor provide/remove buffer locking > io_uring: don't restirct issue_flags for io_openat > io_uring: use better types for cflags > io_uring: refactor out send/recv async setup > io_uring: untie alloc_async_data and needs_async_data > io_uring: rethink def->needs_async_data > io_uring: merge defer_prep() and prep_async() > io_uring: simplify io_resubmit_prep() > > fs/io_uring.c | 210 ++++++++++++++++---------------------------------- > 1 file changed, 68 insertions(+), 142 deletions(-) > Thanks, I've queued this up for 5.13 - I'll most likely rebase this branch a few times going forward, until we have 5.12 fully settled. -- Jens Axboe