Re: [RFC 1/5] Remove unused parameters from intel_plane_wm_parameters

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



General comment (that applies to the whole series); when you write your
commit message, the first line (which becomes the email subject above)
should be prefixed by "drm/i915:"  If your patch is only modifying the
code for a specific platform, you can include that too when appropriate
(e.g., "drm/i915/skl:").

On Wed, Jun 01, 2016 at 08:10:17AM +0100, chix.ding@xxxxxxxxx wrote:
> From: Chi Ding <chix.ding@xxxxxxxxx>
> 
> Everything except fifo_size is unused and therefore removed
> 
> This is the first patch of two-level watermark for VLV/CHV

I think you can leave this line out of your description.  Killing off
dead code / unused fields is worthwhile on its own and doesn't really
need two-level watermarks as justification.

With an updated commit message,

Reviewed-by: Matt Roper <matthew.d.roper@xxxxxxxxx>

> 
> v2: Split the first patch of v1 into the following patches
> - Remove unused parameters from intel_plane_wm_parameters.
> - Rename skl_plane_id to wm_plane_id.
> - Move fifo_size from intel_plane_wm_parameters to vlv_wm_state.
> 
> Signed-off-by: Chi Ding <chix.ding@xxxxxxxxx>
> 
> cc: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx>
> cc: matthew.d.roper@xxxxxxxxx
> cc: yetundex.adebisi@xxxxxxxxx
> 
> ---
>  drivers/gpu/drm/i915/intel_drv.h | 15 ---------------
>  1 file changed, 15 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/intel_drv.h b/drivers/gpu/drm/i915/intel_drv.h
> index 9b5f663..b973b86 100644
> --- a/drivers/gpu/drm/i915/intel_drv.h
> +++ b/drivers/gpu/drm/i915/intel_drv.h
> @@ -697,21 +697,6 @@ struct intel_crtc {
>  };
>  
>  struct intel_plane_wm_parameters {
> -	uint32_t horiz_pixels;
> -	uint32_t vert_pixels;
> -	/*
> -	 *   For packed pixel formats:
> -	 *     bytes_per_pixel - holds bytes per pixel
> -	 *   For planar pixel formats:
> -	 *     bytes_per_pixel - holds bytes per pixel for uv-plane
> -	 *     y_bytes_per_pixel - holds bytes per pixel for y-plane
> -	 */
> -	uint8_t bytes_per_pixel;
> -	uint8_t y_bytes_per_pixel;
> -	bool enabled;
> -	bool scaled;
> -	u64 tiling;
> -	unsigned int rotation;
>  	uint16_t fifo_size;
>  };
>  
> -- 
> 1.8.0.1
> 

-- 
Matt Roper
Graphics Software Engineer
IoTG Platform Enabling & Development
Intel Corporation
(916) 356-2795
_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
https://lists.freedesktop.org/mailman/listinfo/intel-gfx




[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]
  Powered by Linux