On Wed, Apr 27, 2016 at 06:10:52PM -0700, tom.orourke@xxxxxxxxx wrote: > void intel_slpc_init(struct drm_device *dev) > { > - return; > + struct drm_i915_private *dev_priv = dev->dev_private; So what you wanted was dev_priv not dev! > + struct drm_i915_gem_object *obj; > + > + /* Allocate shared data structure */ > + obj = dev_priv->guc.slpc.shared_data_obj; This function (init) should be called exactly once. Do you intend to also be part of the the init_hw phase? -Chris -- Chris Wilson, Intel Open Source Technology Centre _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx