On Wed, Apr 27, 2016 at 06:10:45PM -0700, tom.orourke@xxxxxxxxx wrote: > From: Tom O'Rourke <Tom.O'Rourke@xxxxxxxxx> > > Expose host2guc_action for use by SLPC in intel_slpc.c. > > Expose functions to allocate and release objects used > by GuC to be used for SLPC shared memory object. > > Signed-off-by: Tom O'Rourke <Tom.O'Rourke@xxxxxxxxx> > --- > drivers/gpu/drm/i915/i915_guc_submission.c | 6 +++--- > drivers/gpu/drm/i915/intel_guc.h | 4 ++++ > 2 files changed, 7 insertions(+), 3 deletions(-) > > diff --git a/drivers/gpu/drm/i915/i915_guc_submission.c b/drivers/gpu/drm/i915/i915_guc_submission.c > index 72d6665..aba1155 100644 > --- a/drivers/gpu/drm/i915/i915_guc_submission.c > +++ b/drivers/gpu/drm/i915/i915_guc_submission.c > @@ -75,7 +75,7 @@ static inline bool host2guc_action_response(struct drm_i915_private *dev_priv, > return GUC2HOST_IS_RESPONSE(val); > } > > -static int host2guc_action(struct intel_guc *guc, u32 *data, u32 len) > +int host2guc_action(struct intel_guc *guc, u32 *data, u32 len) That name doesn't fit well into our extern symbol naming scheme. > struct drm_i915_private *dev_priv = guc_to_i915(guc); > u32 status; > @@ -581,7 +581,7 @@ int i915_guc_submit(struct i915_guc_client *client, > * > * Return: A drm_i915_gem_object if successful, otherwise NULL. > */ > -static struct drm_i915_gem_object *gem_allocate_guc_obj(struct drm_device *dev, > +struct drm_i915_gem_object *gem_allocate_guc_obj(struct drm_device *dev, > -static void gem_release_guc_obj(struct drm_i915_gem_object *obj) > +void gem_release_guc_obj(struct drm_i915_gem_object *obj) These functions are not under GEM. Please rename them, they are provided by the GuC using GEM, not vice verse. -Chris -- Chris Wilson, Intel Open Source Technology Centre _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx