From: Robert Foss <robert.foss@xxxxxxxxxxxxx> Changes since v3: - kms_flip.c: Removed drm_fd from data_t, to decrease the number of unrelated changes in the patch. - kms_flip.c: Changed "int valid_tests" to "unsigned valid_tests". - kms_flip.c: Changed crtc_id_flag/crtc_id_to_flag to pipe_id_flag/pipe_id_to_flag. - kms_flip.c: Changed to "vbl.request.type |= crtc_id_flag;". - kms_flip.c: Moved crtc_id_to_flag to igt_kms.c. - kms_flip.c: Renamed crtc_id_to_flag to pipe_id_to_vbl_flag. - kms_flip.c: Changed test busy_mode boolean into mode_busy bitfield in struct data. - igt_kms.h: Moved IGT_PLANE_CURSOR position comment. Changes since v2: - Rebased onto trunk which already contains kms_flip_event_leak changes. Changes since v1: - kms_vblank: Removed un-used members of data_t struct. - Rename plane_counter to n_planes. - Removed un-needed handling CURSOR plane location. - Added names for additional planes in update kmstest_plane_name. Robert Foss (5): lib/igt_kms: Add support for up to 10 planes. lib/igt_kms: Fix plane counting in igt_display_init. lib/igt_kms: Switch to verbose assert. kms_vblank: Switch from using crtc0 statically to explicitly setting mode. lib/igt_kms: Added pipe_id_to_vbl_flag() to igt_kms. lib/igt_kms.c | 30 +++++++++- lib/igt_kms.h | 9 ++- tests/kms_vblank.c | 162 ++++++++++++++++++++++++++++++++++++++++++++--------- 3 files changed, 172 insertions(+), 29 deletions(-) -- 2.5.0 _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx