On Wed, Mar 16, 2016 at 12:21:39PM +0200, Jani Nikula wrote: > The enum mipi_dsi_pixel_format defines MIPI_DSI_FMT_RGB666 for the > "loose" 24 bpp format and MIPI_DSI_FMT_RGB666_PACKED for the 18 bpp > format. We have this the other way round, defining a loose version for > 24 bpp. > > Follow suit with what's in enum mipi_dsi_pixel_format to avoid future > confusion. Rename > > VID_MODE_FORMAT_RGB666 -> VID_MODE_FORMAT_RGB666_PACKED > VID_MODE_FORMAT_RGB666_LOOSE -> VID_MODE_FORMAT_RGB666 This goes against our spec a bit, and the DSI spec calls these "packed" and "loosly packed". So I'm not entirely thrilled about the names used in the mipi_dsi_pixel_format either. I think the best option would be to call them something like 666_18 and 666_24 to avoid all the confusion. But patch looks sane anyway so Reviewed-by: Ville Syrjälä <ville.syrjala@xxxxxxxxxxxxxxx> > > Signed-off-by: Jani Nikula <jani.nikula@xxxxxxxxx> > --- > drivers/gpu/drm/i915/i915_reg.h | 4 ++-- > drivers/gpu/drm/i915/intel_dsi_pll.c | 4 ++-- > 2 files changed, 4 insertions(+), 4 deletions(-) > > diff --git a/drivers/gpu/drm/i915/i915_reg.h b/drivers/gpu/drm/i915/i915_reg.h > index 7dfc4007f3fa..85ceec611412 100644 > --- a/drivers/gpu/drm/i915/i915_reg.h > +++ b/drivers/gpu/drm/i915/i915_reg.h > @@ -7887,8 +7887,8 @@ enum skl_disp_power_wells { > #define VID_MODE_FORMAT_MASK (0xf << 7) > #define VID_MODE_NOT_SUPPORTED (0 << 7) > #define VID_MODE_FORMAT_RGB565 (1 << 7) > -#define VID_MODE_FORMAT_RGB666 (2 << 7) > -#define VID_MODE_FORMAT_RGB666_LOOSE (3 << 7) > +#define VID_MODE_FORMAT_RGB666_PACKED (2 << 7) > +#define VID_MODE_FORMAT_RGB666 (3 << 7) > #define VID_MODE_FORMAT_RGB888 (4 << 7) > #define CMD_MODE_CHANNEL_NUMBER_SHIFT 5 > #define CMD_MODE_CHANNEL_NUMBER_MASK (3 << 5) > diff --git a/drivers/gpu/drm/i915/intel_dsi_pll.c b/drivers/gpu/drm/i915/intel_dsi_pll.c > index 2451c84949bd..9ef0f7806e4a 100644 > --- a/drivers/gpu/drm/i915/intel_dsi_pll.c > +++ b/drivers/gpu/drm/i915/intel_dsi_pll.c > @@ -37,10 +37,10 @@ int dsi_pixel_format_bpp(int pixel_format) > switch (pixel_format) { > default: > case VID_MODE_FORMAT_RGB888: > - case VID_MODE_FORMAT_RGB666_LOOSE: > + case VID_MODE_FORMAT_RGB666: > bpp = 24; > break; > - case VID_MODE_FORMAT_RGB666: > + case VID_MODE_FORMAT_RGB666_PACKED: > bpp = 18; > break; > case VID_MODE_FORMAT_RGB565: > -- > 2.1.4 -- Ville Syrjälä Intel OTC _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx https://lists.freedesktop.org/mailman/listinfo/intel-gfx