This patch aims to create a separate lib for power management related helpers. Initially it only contains code that modify settings for external components (to handle components with default settings that prevents entering deeper sleep states), but moving i915-related power management helpers to this lib would probably make sense too. v2: Change name of library to igt_pm Namespace all exported functions with igt_pm_ David Weinehall (1): lib/igt_pm: Lib for power management lib/Makefile.sources | 2 + lib/igt.h | 1 + lib/igt_aux.c | 15 +--- lib/igt_pm.c | 233 +++++++++++++++++++++++++++++++++++++++++++++++++++ lib/igt_pm.h | 31 +++++++ tests/pm_lpsp.c | 25 +----- tests/pm_rpm.c | 29 ++----- 7 files changed, 279 insertions(+), 57 deletions(-) create mode 100644 lib/igt_pm.c create mode 100644 lib/igt_pm.h -- 2.6.3 _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/intel-gfx