On Mon, Dec 14, 2015 at 11:16:08AM +0530, ankitprasad.r.sharma@xxxxxxxxx wrote: > @@ -2039,6 +2052,8 @@ struct drm_i915_gem_object { > struct list_head obj_exec_link; > > struct list_head batch_pool_link; > + /** Used during stolen memory allocations to temporarily hold a ref */ > + struct list_head stolen_link; It would be very useful to me if you could rename this tmp_link. /** Used by eviction/debugfs only under the struct_mutex when the caller * is certain they are the only users of this list. */ > + INIT_LIST_HEAD(&obj->stolen_link); Doesn't require init. -Chris -- Chris Wilson, Intel Open Source Technology Centre _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/intel-gfx