The per-slice/subslice INSTDONE patchset from Ben [1] will need the subslice/slice masks in addition to the corresponding counts that we maintain atm. So I added support to store the masks instead of the counts and calculate the counts whenever we need them based on the masks. While at it I also noticed that the SSEU readout code could be simplified by reusing the data structure storing the SSEU properties. Tested on BXT/SKL. [1] http://lists.freedesktop.org/archives/intel-gfx/2015-September/077050.html Imre Deak (7): drm/i915: sseu: move sseu_dev_status to i915_drv.h drm/i915: sseu: use sseu_dev_info in device info drm/i915: sseu: simplify debugfs status/info printing drm/i915: sseu: convert slice count field to mask drm/i915: sseu: convert subslice count fields to subslice mask drm/i915: sseu: add debug printf for slice/subslice masks drm/i915/bdw: sseu: fix sseu status parsing drivers/gpu/drm/i915/i915_debugfs.c | 134 +++++++++++++++----------------- drivers/gpu/drm/i915/i915_dma.c | 115 +++++++++++++-------------- drivers/gpu/drm/i915/i915_drv.h | 28 ++++--- drivers/gpu/drm/i915/intel_lrc.c | 14 ++-- drivers/gpu/drm/i915/intel_pm.c | 2 +- drivers/gpu/drm/i915/intel_ringbuffer.c | 4 +- 6 files changed, 150 insertions(+), 147 deletions(-) -- 2.1.4 _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/intel-gfx