2015-08-14 9:50 GMT-03:00 Daniel Vetter <daniel@xxxxxxxx>: > On Thu, Aug 13, 2015 at 01:31:38PM -0700, Jesse Barnes wrote: >> These always need to pass for basic PM functionality. >> >> Signed-off-by: Jesse Barnes <jbarnes@xxxxxxxxxxxxxxxx> >> --- >> tests/pm_rpm.c | 4 ++-- >> 1 file changed, 2 insertions(+), 2 deletions(-) >> >> diff --git a/tests/pm_rpm.c b/tests/pm_rpm.c >> index d509fa8..7ae5806 100644 >> --- a/tests/pm_rpm.c >> +++ b/tests/pm_rpm.c >> @@ -1832,11 +1832,11 @@ int main(int argc, char *argv[]) >> stay_subtest(); >> >> /* Essential things */ >> - igt_subtest("rte") >> + igt_subtest("basic-rte") > > I thought our BAT criteria would be basic|rte? > > rte is runtime environment check and more along the lines of "did QA set > up their machine correctly", so imo good to keep separate. When I originally named the test, I thought the test would catch bad machine setups more often than the other case. But after QA managed to properly setup their machines, we got tons and tons of Kernel regressions that broke pm_rpm/rte. So "basic-rte" wouldn't be a bad name, since we can actually catch both bad setups and fundamental regressions here. > -Daniel > >> basic_subtest(); >> igt_subtest("drm-resources-equal") >> drm_resources_equal_subtest(); >> - igt_subtest("pci-d3-state") >> + igt_subtest("basic-pci-d3-state") >> pci_d3_state_subtest(); >> >> /* Basic modeset */ >> -- >> 1.9.1 >> >> _______________________________________________ >> Intel-gfx mailing list >> Intel-gfx@xxxxxxxxxxxxxxxxxxxxx >> http://lists.freedesktop.org/mailman/listinfo/intel-gfx > > -- > Daniel Vetter > Software Engineer, Intel Corporation > http://blog.ffwll.ch > _______________________________________________ > Intel-gfx mailing list > Intel-gfx@xxxxxxxxxxxxxxxxxxxxx > http://lists.freedesktop.org/mailman/listinfo/intel-gfx -- Paulo Zanoni _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/intel-gfx