On Fri, Jun 05, 2015 at 12:00:54PM +0100, Chris Wilson wrote: > On Fri, Jun 05, 2015 at 11:34:01AM +0100, Arun Siluvery wrote: > > + /* FIXME: fill unused locations with NOOPs. > > + * Replace these instructions with WA > > + */ > > + while (index < end) > > + reg_state[index++] = MI_NOOP; > > I found calling it reg_state was very confusing. Maybe batch, bb, data or cmd? Concurred, reg_state sounds like an mmio dump not a batchbuffer. wa_batch would be my naming bikeshed, but I'd go with either. If this is all that needs changing I can do that while applying patches. -Daniel -- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/intel-gfx