[PATCH i-g-t] docs: avoid escaping characters in documentation comments

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Avoid having to escape certain characters in documentation comments by
not allowing docbook markup tags. Markdown formatting in documentation
comments is still supported.

Signed-off-by: Thomas Wood <thomas.wood@xxxxxxxxx>
---
 docs/reference/intel-gpu-tools/Makefile.am | 2 +-
 lib/igt_aux.c                              | 2 +-
 lib/igt_core.c                             | 4 ++--
 lib/igt_debugfs.c                          | 4 ++--
 4 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/docs/reference/intel-gpu-tools/Makefile.am b/docs/reference/intel-gpu-tools/Makefile.am
index 0033295..8364247 100644
--- a/docs/reference/intel-gpu-tools/Makefile.am
+++ b/docs/reference/intel-gpu-tools/Makefile.am
@@ -99,7 +99,7 @@ SCAN_OPTIONS=--rebuild-sections
 
 # Extra options to supply to gtkdoc-mkdb.
 # e.g. MKDB_OPTIONS=--xml-mode --output-format=xml
-MKDB_OPTIONS=--xml-mode --output-format=xml
+MKDB_OPTIONS=--output-format=xml
 
 # Extra options to supply to gtkdoc-mktmpl
 # e.g. MKTMPL_OPTIONS=--only-section-tmpl
diff --git a/lib/igt_aux.c b/lib/igt_aux.c
index 788ac3f..e011ef4 100644
--- a/lib/igt_aux.c
+++ b/lib/igt_aux.c
@@ -413,7 +413,7 @@ void igt_drop_root(void)
  * @var: var lookup to to enable this wait
  *
  * Waits for a key press when run interactively and when the corresponding debug
- * var is set in the --interactive-debug=&lt;var&gt; variable. Multiple keys
+ * var is set in the --interactive-debug=<var> variable. Multiple keys
  * can be specified as a comma-separated list or alternatively "all" if a wait
  * should happen for all cases.
  *
diff --git a/lib/igt_core.c b/lib/igt_core.c
index 700604f..7d04f2c 100644
--- a/lib/igt_core.c
+++ b/lib/igt_core.c
@@ -157,10 +157,10 @@
  *   test logic.
  *
  * - When adding a new feature test function which uses igt_skip() internally,
- *   use the &lt;prefix&gt;_require_&lt;feature_name&gt; naming scheme. When you
+ *   use the <prefix>_require_<feature_name> naming scheme. When you
  *   instead add a feature test function which returns a boolean, because your
  *   main test logic must take different actions depending upon the feature's
- *   availability, then instead use the &lt;prefix&gt;_has_&lt;feature_name&gt;.
+ *   availability, then instead use the <prefix>_has_<feature_name>.
  *
  * - As already mentioned eschew explicit error handling logic as much as
  *   possible. If your test absolutely has to handle the error of some function
diff --git a/lib/igt_debugfs.c b/lib/igt_debugfs.c
index df7f453..e7b69de 100644
--- a/lib/igt_debugfs.c
+++ b/lib/igt_debugfs.c
@@ -142,7 +142,7 @@ static igt_debugfs_t *__igt_debugfs_singleton(void)
  * @mode: mode bits as used by open()
  *
  * This opens a debugfs file as a Unix file descriptor. The filename should be
- * relative to the drm device's root, i.e without "drm/&lt;minor&gt;".
+ * relative to the drm device's root, i.e without "drm/<minor>".
  *
  * Returns:
  * The Unix file descriptor for the debugfs file or -1 if that didn't work out.
@@ -165,7 +165,7 @@ int igt_debugfs_open(const char *filename, int mode)
  * @mode: mode string as used by fopen()
  *
  * This opens a debugfs file as a libc FILE. The filename should be
- * relative to the drm device's root, i.e without "drm/&lt;minor&gt;".
+ * relative to the drm device's root, i.e without "drm/<minor>".
  *
  * Returns:
  * The libc FILE pointer for the debugfs file or NULL if that didn't work out.
-- 
2.1.0

_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/intel-gfx





[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]
  Powered by Linux