On 13/02/2015 12:17, Chris Wilson wrote:
On Fri, Feb 13, 2015 at 11:48:58AM +0000, John.C.Harrison@xxxxxxxxx wrote:
From: John Harrison <John.C.Harrison@xxxxxxxxx>
Now that everything above has been converted to use requests,
intel_logical_ring_begin() can be updated to take a request instead of a
ringbuf/context pair. This also means that it no longer needs to lazily allocate
a request if no-one happens to have done it earlier.
Note that this change makes the execlist signature the same as the legacy
version. Thus the two functions could be merged into a ring->begin() wrapper if
required.
It should be noted that you don't even need to virtualise the
function... Please kill all the duplicated code.
-Chris
As noted in the cover letter, quite a lot of the execlist vs legacy
duplication could be resolved back to a single code path. However,
that was quite a large war discussion first time
around. So I would rather leave that for another patch series once
people actually decide what the best direction really is.
|
_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/intel-gfx