Our tooling doesn't cope with () in the testnames (piglit becomes all confused apparently) and the naming convention says to use "blt" and "render". Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=88220 Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=88349 Signed-off-by: Daniel Vetter <daniel.vetter@xxxxxxxxx> --- tests/gem_concurrent_blit.c | 4 ++-- tests/gem_mmap_wc.c | 2 +- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/tests/gem_concurrent_blit.c b/tests/gem_concurrent_blit.c index 48ee48a60c0a..beb96757eeb7 100644 --- a/tests/gem_concurrent_blit.c +++ b/tests/gem_concurrent_blit.c @@ -735,8 +735,8 @@ run_basic_modes(const struct access_mode *mode, void (*require)(void); } hangs[] = { { "", no_hang, no_require }, - { "-hang(bcs)", bcs_hang, hang_require }, - { "-hang(rcs)", rcs_hang, hang_require }, + { "-hang-blt", bcs_hang, hang_require }, + { "-hang-render", rcs_hang, hang_require }, { NULL, NULL }, }, *h; drm_intel_bo *src[MAX_NUM_BUFFERS], *dst[MAX_NUM_BUFFERS], *dummy = NULL; diff --git a/tests/gem_mmap_wc.c b/tests/gem_mmap_wc.c index c945ba85569e..87916b6e81c0 100644 --- a/tests/gem_mmap_wc.c +++ b/tests/gem_mmap_wc.c @@ -429,7 +429,7 @@ igt_main igt_fixture fd = drm_open_any(); - igt_subtest("invalid flags") + igt_subtest("invalid-flags") test_invalid_flags(fd); igt_subtest("copy") test_copy(fd); -- 2.1.4 _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/intel-gfx