Re: [PATCH 7/9] drm/i915: Rename the forcewake get/put functions

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Jan 16, 2015 at 11:34:40AM +0200, Mika Kuoppala wrote:
> @@ -356,14 +356,21 @@ void intel_uncore_sanitize(struct drm_device *dev)
>  	intel_disable_gt_powersave(dev);
>  }
>  
> -/*
> - * Generally this is called implicitly by the register read function. However,
> - * if some sequence requires the GT to not power down then this function should
> - * be called at the beginning of the sequence followed by a call to
> - * gen6_gt_force_wake_put() at the end of the sequence.
> +/**
> + * intel_uncore_forcewake_get - grab forcewake domain references
> + * @dev_priv: i915 device instance
> + * @fw_domains: forcewake domains to get reference on
> + *
> + * This function can be used get GT's forcewake domain references.
> + * Normal register access will handle the forcewake domains automatically.
> + * However if some sequence requires the GT to not power down a particular
> + * forcewake domains this function should be called at the beginning of the
> + * sequence. And subsequently the reference should be dropped by symmetric
> + * call to intel_unforce_forcewake_put(). Usually caller wants all the domains
> + * to be kept awake so the @fw_domains would be then FORCEWAKE_ALL.
>   */

intel_uncore.c isn't pulled into the drm.tmpl docbook file, which means
your shiny new kerneldoc here won't be used. Can you please supply a
follow-up patch to remedy this?

Thanks, Daniel
-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch
_______________________________________________
Intel-gfx mailing list
Intel-gfx@xxxxxxxxxxxxxxxxxxxxx
http://lists.freedesktop.org/mailman/listinfo/intel-gfx




[Index of Archives]     [Linux USB Devel]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]
  Powered by Linux