On Tue, Oct 28, 2014 at 7:20 AM, Jani Nikula <jani.nikula@xxxxxxxxx> wrote: > In the interest of reducing magic numbers and having to cross check with > the specs all the time. > > Signed-off-by: Jani Nikula <jani.nikula@xxxxxxxxx> > --- > include/drm/drm_edid.h | 102 +++++++++++++++++++++++++++++++++++++++++++++++++ > 1 file changed, 102 insertions(+) > > diff --git a/include/drm/drm_edid.h b/include/drm/drm_edid.h > index b96031d947a0..c2f1bfa22010 100644 > --- a/include/drm/drm_edid.h > +++ b/include/drm/drm_edid.h > @@ -207,6 +207,61 @@ struct detailed_timing { > #define DRM_EDID_HDMI_DC_30 (1 << 4) > #define DRM_EDID_HDMI_DC_Y444 (1 << 3) > > +/* ELD Header Block */ > +#define DRM_ELD_HEADER_BLOCK_SIZE 4 > + > +#define DRM_ELD_VER 0 > +# define DRM_ELD_VER_SHIFT 3 > +# define DRM_ELD_VER_MASK (0x1f << 3) > + > +#define DRM_ELD_BASELINE_ELD_LEN 2 /* in dwords! */ > + > +/* ELD Baseline Block for ELD_Ver == 2 */ > +#define DRM_ELD_CEA_EDID_VER_MNL 4 Oh, this VER_MNL name confused me a lot during review.... confusing with MNN_SHIFT. But since I don't have a better suggestions nevermind ;) > +# define DRM_ELD_CEA_EDID_VER_SHIFT 5 > +# define DRM_ELD_CEA_EDID_VER_MASK (7 << 5) > +# define DRM_ELD_CEA_EDID_VER_NONE (0 << 5) > +# define DRM_ELD_CEA_EDID_VER_CEA861 (1 << 5) > +# define DRM_ELD_CEA_EDID_VER_CEA861A (2 << 5) > +# define DRM_ELD_CEA_EDID_VER_CEA861BCD (3 << 5) > +# define DRM_ELD_MNL_SHIFT 0 > +# define DRM_ELD_MNL_MASK (0x1f << 0) > + > +#define DRM_ELD_SAD_COUNT_CONN_TYPE 5 > +# define DRM_ELD_SAD_COUNT_SHIFT 4 > +# define DRM_ELD_SAD_COUNT_MASK (0xf << 4) > +# define DRM_ELD_CONN_TYPE_SHIFT 2 > +# define DRM_ELD_CONN_TYPE_MASK (3 << 2) > +# define DRM_ELD_CONN_TYPE_HDMI (0 << 2) > +# define DRM_ELD_CONN_TYPE_DP (1 << 2) > +# define DRM_ELD_SUPPORTS_AI (1 << 1) > +# define DRM_ELD_SUPPORTS_HDCP (1 << 0) > + > +#define DRM_ELD_AUD_SYNCH_DELAY 6 /* in units of 2 ms */ > +# define DRM_ELD_AUD_SYNCH_DELAY_MAX 0xfa /* 500 ms */ > + > +#define DRM_ELD_SPEAKER 7 > +# define DRM_ELD_SPEAKER_RLRC (1 << 6) > +# define DRM_ELD_SPEAKER_FLRC (1 << 5) > +# define DRM_ELD_SPEAKER_RC (1 << 4) > +# define DRM_ELD_SPEAKER_RLR (1 << 3) > +# define DRM_ELD_SPEAKER_FC (1 << 2) > +# define DRM_ELD_SPEAKER_LFE (1 << 1) > +# define DRM_ELD_SPEAKER_FLR (1 << 0) > + > +#define DRM_ELD_PORT_ID 8 /* offsets 8..15 inclusive */ > +# define DRM_ELD_PORT_ID_LEN 8 > + > +#define DRM_ELD_MANUFACTURER_NAME0 16 > +#define DRM_ELD_MANUFACTURER_NAME1 17 > + > +#define DRM_ELD_PRODUCT_CODE0 18 > +#define DRM_ELD_PRODUCT_CODE1 19 > + > +#define DRM_ELD_MONITOR_NAME_STRING 20 /* offsets 20..(20+mnl-1) inclusive */ > + > +#define DRM_ELD_CEA_SAD(mnl, sad) (20 + (mnl) + 3 * (sad)) > + > struct edid { > u8 header[8]; > /* Vendor & product info */ > @@ -279,4 +334,51 @@ int > drm_hdmi_vendor_infoframe_from_display_mode(struct hdmi_vendor_infoframe *frame, > const struct drm_display_mode *mode); > > +/** > + * drm_eld_mnl - Get ELD monitor name length in bytes. > + * @eld: pointer to an eld memory structure with mnl set > + */ > +static inline int drm_eld_mnl(const uint8_t *eld) > +{ > + return (eld[DRM_ELD_CEA_EDID_VER_MNL] & DRM_ELD_MNL_MASK) >> DRM_ELD_MNL_SHIFT; > +} > + > +/** > + * drm_eld_sad_count - Get ELD SAD count. > + * @eld: pointer to an eld memory structure with sad_count set > + */ > +static inline int drm_eld_sad_count(const uint8_t *eld) > +{ > + return (eld[DRM_ELD_SAD_COUNT_CONN_TYPE] & DRM_ELD_SAD_COUNT_MASK) >> > + DRM_ELD_SAD_COUNT_SHIFT; > +} > + > +/** > + * drm_eld_calc_baseline_block_size - Calculate baseline block size in bytes > + * @eld: pointer to an eld memory structure with mnl and sad_count set > + * > + * This is a helper for determining the payload size of the baseline block, in > + * bytes, for e.g. setting the Baseline_ELD_Len field in the ELD header block. > + */ > +static inline int drm_eld_calc_baseline_block_size(const uint8_t *eld) > +{ > + return DRM_ELD_MONITOR_NAME_STRING - DRM_ELD_HEADER_BLOCK_SIZE + > + drm_eld_mnl(eld) + drm_eld_sad_count(eld) * 3; > +} > + > +/** > + * drm_eld_size - Get ELD size in bytes > + * @eld: pointer to a complete eld memory structure > + * > + * The returned value does not include the vendor block. It's vendor specific, > + * and comprises of the remaining bytes in the ELD memory buffer after > + * drm_eld_size() bytes of header and baseline block. > + * > + * The returned value is guaranteed to be a multiple of 4. > + */ > +static inline int drm_eld_size(const uint8_t *eld) > +{ > + return DRM_ELD_HEADER_BLOCK_SIZE + eld[DRM_ELD_BASELINE_ELD_LEN] * 4; > +} > + > #endif /* __DRM_EDID_H__ */ > -- > 2.1.1 > Reviewed-by: Rodrigo Vivi <rodrigo.vivi@xxxxxxxxx> -- Rodrigo Vivi Blog: http://blog.vivi.eng.br _______________________________________________ Intel-gfx mailing list Intel-gfx@xxxxxxxxxxxxxxxxxxxxx http://lists.freedesktop.org/mailman/listinfo/intel-gfx